How to change the PHP version on your shared servers
   
 

In some cases correct functioning of your website depends on PHP version installed on the server.

Thanks to PHP Selector function it is possible to select the necessary PHP version as well as enable/disable certain PHP modules and functions.
 

To change PHP version, follow the steps below:

1. Log in to your cPanel account.
2. Scroll down to Software/Services section > Select PHP Version



3. Here you will see the list of available modules and extensions.

If you do not need to change PHP version and just want to turn on/off specific extensions, you can do this by ticking/unticking the corresponding boxes.

Use PHP Version drop-down box to select the required version, click on Set as current in order to apply the changes.

NOTE: the ‘native’ PHP version does not allow changing any options



5. To change individual settings within PHP version in question, click on Switch to PHP Settings

By clicking on one of the options (in grey), you will be presented with a drop-down list to change specific settings. Hit Apply to implement the settings.




NOTE: it is recommended to update your website scripts and use PHP 5.4. If the latest software you run for your websites are not yet compiled for PHP 5.4, be advised to contact script vendor for compatibility patch.

NOTE 2: if you used php.ini file for editing your account PHP configuration before, you will need to replicate the custom values using PHP Selector tool.

 
 

 




© Copyright 1994 - VarniTec Services Inc.